Hellhound Games Website Offline

Major incident Hellhound Games Website
2019-09-28 11:52 MST · 4 hours, 29 minutes

Updates

Resolved

We are done monitoring the website. Everything has returned to normal. Remember to check out our new game coming soon to Xbox

https://hellhoundgames.net

November 4, 2021 · 08:24 MST
Monitoring

We have repaired the issue and will continue to monitor it throughout the day.

November 4, 2021 · 08:24 MST
Issue

Our website was giving issues by not showing the main horizontal menu properly. We have closed the site to work on the issue. We will update you when we have more information

November 4, 2021 · 08:24 MST

← Back