Major Storm/Power Outage

Major incident The Explorer Remastered
2019-08-07 16:26 MST · 3 hours, 37 minutes

Updates

Resolved

The storm is over and all services have returned back to normal.

November 4, 2021 · 08:24 MST
Issue

We are currently having a huge storm at our HQ power is expected to go out. We have backed up all game files to an offsite server. Please expect game to take longer than usual on boot while it changes server locations. Thank you we will keep you updated as we continue.

November 4, 2021 · 08:24 MST

← Back